вопросы и ответы по 1С
каталог программ 1с
книги об 1с, новости, статьи
скачать бесплатно программы

Поиск по сайту "Всё про 1С":
| Вопросы и ответы | Партнеры | Скачать | Книги | Статьи | Новости | Ссылки | Отчеты и обработки для 1С

1с: В 1С:Зарплата и Кадры 7.7 релиз 284. При открытии Формы Т-2 вываливается ошибка, если у сотрудника был "Отпуск по уходу за ребенком" ...

вопросы и ответы :: 1С Зарплата и Кадры 7.7

Вопрос по 1С Зарплата и Кадры 7.7:

В 1С:Зарплата и Кадры 7.7 релиз 284. При открытии Формы Т-2 вываливается ошибка, если у сотрудника был "Отпуск по уходу за ребенком"
Если ДокОтпуск.ДокОснование.Вид() = "ПриказОбУвольнении" Тогда
{Обработка.ФормаТ2.Форма.Модуль(408)}: Поле агрегатного объекта не обнаружено (ДокОснование)

Ответ 1с:

Для исправления данной ошибки обратитесь к специалисту по конфигурированию 1С:Предприятия 7.7.

кусок кода

Если ДокОтпуск.ДокОснование.Вид() = "ПриказОбУвольнении" Тогда
ТабОтп.ПриказПоОтпуску = ДокОтпуск.ДокОснование;
Иначе
ТабОтп.ПриказПоОтпуску = ПолучитьПриказПоОтпуску(ДокОтпуск.ТекущийДокумент());
КонецЕсли;

заменить на

ТабОтп.ПриказПоОтпуску = ПолучитьПриказПоОтпуску(ДокОтпуск.ТекущийДокумент());

как и было в релизе 283. А в процедуре ПолучитьПриказПоОтпуску() после

Если ДокНачОтп.Вид() = "ОтпускПоУходуЗаРебенком" Тогда
ДокументОснование = ДокНачОтп.ДокументОснование;
Иначе
ДокументОснование = ДокНачОтп.ДокОснование;
КонецЕсли;

добавить

Если ДокументОснование.Вид() = "ПриказОбУвольнении" Тогда
Возврат ДокументОснование;
КонецЕсли;

Вы можете ДОБАВИТЬ СВОЙ комментарий, отзыв, вопрос.

Еще вопросы и ответы по 1С Зарплата и Кадры 7.7:

Как установить проверку штатного расписания в 1С:Зарплата и кадры 7.7?

Как выгрузить данные из Бухгалтерия предприятия 8 для загрузки в Зарплату и кадры 7.7?

Как в 1С:Зарплата и кадры 7.7 осуществлять перерасчет отпуска?

Как добавить новый счет в 1С:Зарплата и Кадры?

Как сделать выгрузку плана счетов из 1С:Бухгалтерии 7.7 в 1С:Зарплата и кадры 7.7?

Сотрудница в программе 1С:Зарплата и Кадры 7.7 в период с 14.02.07г. по 28.08.09 должна находится в отпуске ...

Добавление комментария:

Чтобы Ваш комментарий был опубликован – постарайтесь писать грамотно и по существу.

Комментарий
или отзыв:
Оценка: оценку выставлять не обязательно
если ставите оценку без комментария, то укажите хотя бы имя
Ваши данные
(имя и т.п.):
отображаются на сайте
Email: сообщать о новых комментариях

1С Бухгалтерия Предприятия 8

1С Бухгалтерия 7.7

1С Зарплата и Управление Персоналом 8

1С Зарплата и Кадры 7.7

1С Управление Торговлей 8

1С Торговля и Склад 7.7

1С Комплексная 7.7

1С Производство + Услуги + Бухгалтерия 7.7

1С общие вопросы

 
vsepro1s.ru - программа 1с 8.3, 8.2, 8, 7.7, 1С предприятие
разработка и создание портала, сопровождение: krav.ru